Advisory Database
  • Advisories
  • Dependency Scanning
  1. maven
  2. ›
  3. org.apache.jspwiki/jspwiki-main
  4. ›
  5. CVE-2022-34158

CVE-2022-34158: Cross-Site Request Forgery (CSRF)

August 4, 2022 (updated August 10, 2022)

A carefully crafted invocation on the Image plugin could trigger an CSRF vulnerability on Apache JSPWiki before 2.11.3, which could allow a group privilege escalation of the attacker’s account. Further examination of this issue established that it could also be used to modify the email associated with the attacked account, and then a reset password request from the login page.

References

  • jspwiki-wiki.apache.org/Wiki.jsp?page=CVE-2022-34158
  • nvd.nist.gov/vuln/detail/CVE-2022-34158

Code Behaviors & Features

Detect and mitigate CVE-2022-34158 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 2.11.3

Fixed versions

  • 2.11.3

Solution

Upgrade to version 2.11.3 or above.

Impact 8.8 HIGH

CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

Learn more about CVSS

Weakness

  • CWE-352: Cross-Site Request Forgery (CSRF)

Source file

maven/org.apache.jspwiki/jspwiki-main/CVE-2022-34158.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:58 +0000.