CVE-2026-24713: Apache IoTDB has an Improper Input Validation vulnerability
(updated )
Improper Input Validation vulnerability in Apache IoTDB.
This issue affects Apache IoTDB: from 1.0.0 before 1.3.7, from 2.0.0 before 2.0.7.
Users are recommended to upgrade to version 1.3.7 or 2.0.7, which fixes the issue.
References
- github.com/advisories/GHSA-6w48-2g9j-v9q5
- github.com/apache/iotdb
- github.com/apache/iotdb/commit/8fbfddc5f83771f1b339c457de597fe877f686d2
- github.com/apache/iotdb/compare/v1.3.6...v1.3.7
- github.com/apache/iotdb/compare/v2.0.6...v2.0.7
- github.com/apache/iotdb/releases/tag/v1.3.7
- github.com/apache/iotdb/releases/tag/v2.0.7
- lists.apache.org/thread/vopgv6y2ccw403b0zv7rvojjrh7x1j5p
- nvd.nist.gov/vuln/detail/CVE-2026-24713
Code Behaviors & Features
Detect and mitigate CVE-2026-24713 with GitLab Dependency Scanning
Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →