CVE-2024-26579: Apache Inlong Deserialization of Untrusted Data vulnerability
(updated )
Deserialization of Untrusted Data vulnerability in Apache InLong. This issue affects Apache InLong: from 1.7.0 through 1.11.0. The attackers can bypass using malicious parameters.
Users are advised to upgrade to Apache InLong’s 1.12.0 or cherry-pick [1], [2] to solve it.
[1] https://github.com/apache/inlong/pull/9694
[2] https://github.com/apache/inlong/pull/9707
References
- github.com/advisories/GHSA-fgh3-pwmp-3qw3
- github.com/apache/inlong
- github.com/apache/inlong/commit/23e3e00cae1fd120b089fca54f7440945dfe11a4
- github.com/apache/inlong/commit/cdf616670942fec7d09fae2452e2ea215205dd1d
- github.com/apache/inlong/pull/9694
- github.com/apache/inlong/pull/9707
- lists.apache.org/thread/d2hndtvh6bll4pkl91o2oqxyynhr54k3
- nvd.nist.gov/vuln/detail/CVE-2024-26579
Code Behaviors & Features
Detect and mitigate CVE-2024-26579 with GitLab Dependency Scanning
Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →