Advisory Database
  • Advisories
  • Dependency Scanning
  1. maven
  2. ›
  3. org.apache.geode/geode-web-api
  4. ›
  5. CVE-2024-44088

CVE-2024-44088: Apache Geode web-api is vulnerable to Cross-site Scripting

October 14, 2025 (updated November 5, 2025)

Malicious script injection (‘Cross-site Scripting’) vulnerability in Apache Geode web-api (REST). This vulnerability allows an attacker that tricks a logged-in user into clicking a specially-crafted link to execute code on the returned page, which could lead to theft of the user’s session information and even account takeover.

This issue affects Apache Geode: all versions prior to 1.15.2.

Users are recommended to upgrade to version 1.15.2, which fixes the issue.

References

  • github.com/advisories/GHSA-w595-4975-gm3h
  • github.com/apache/geode
  • lists.apache.org/thread/161r34nokmcc0w74mnf04lskgb8g1d3g
  • nvd.nist.gov/vuln/detail/CVE-2024-44088

Code Behaviors & Features

Detect and mitigate CVE-2024-44088 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions starting from 1.1.0 before 1.15.2

Fixed versions

  • 1.15.2

Solution

Upgrade to version 1.15.2 or above.

Impact 6.1 MEDIUM

CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N

Learn more about CVSS

Weakness

  • CWE-79: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')

Source file

maven/org.apache.geode/geode-web-api/CVE-2024-44088.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:01 +0000.