Advisory Database
  • Advisories
  • Dependency Scanning
  1. maven
  2. ›
  3. org.apache.geode/geode-core
  4. ›
  5. CVE-2022-37023

CVE-2022-37023: Deserialization of Untrusted Data

August 31, 2022 (updated September 6, 2022)

Apache Geode versions prior to 1.15.0 is vulnerable to a deserialization of untrusted data flaw when using REST API on Java 8 or Java 11. Any user wishing to protect against deserialization attacks involving REST APIs should upgrade to Apache Geode 1.15 and follow the documentation for details on enabling “validate-serializable-objects=true” and specifying any user classes that may be serialized/deserialized with “serializable-object-filter”. Enabling “validate-serializable-objects” may impact performance.

References

  • lists.apache.org/thread/6js89pbqrp52zlpwgry5fsdn76gxbbfj
  • nvd.nist.gov/vuln/detail/CVE-2022-37023

Code Behaviors & Features

Detect and mitigate CVE-2022-37023 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 1.15.0

Fixed versions

  • 1.15.0

Solution

Upgrade to version 1.15.0 or above.

Impact 6.5 MEDIUM

CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H

Learn more about CVSS

Weakness

  • CWE-502: Deserialization of Untrusted Data

Source file

maven/org.apache.geode/geode-core/CVE-2022-37023.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:15:42 +0000.