Advisory Database
  • Advisories
  • Dependency Scanning
  1. maven
  2. ›
  3. org.apache.felix/org.apache.felix.http.webconsoleplugin
  4. ›
  5. CVE-2025-27867

CVE-2025-27867: Apache Felix HTTP Webconsole Plugin: XSS in HTTP Webconsole Plugin

March 12, 2025 (updated March 21, 2025)

Improper Neutralization of Input During Web Page Generation (‘Cross-site Scripting’) vulnerability in Apache Felix HTTP Webconsole Plugin.

This issue affects Apache Felix HTTP Webconsole Plugin: from Version 1.X through 1.2.0.

Users are recommended to upgrade to version 1.2.2, which fixes the issue.

References

  • github.com/advisories/GHSA-2cv6-4f2r-jq2c
  • github.com/apache/felix-dev
  • lists.apache.org/thread/y83f2rvm8bccr5ctgv7mzxd69p6f77dp
  • nvd.nist.gov/vuln/detail/CVE-2025-27867

Code Behaviors & Features

Detect and mitigate CVE-2025-27867 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 1.2.2

Fixed versions

  • 1.2.2

Solution

Upgrade to version 1.2.2 or above.

Impact 5.6 MEDIUM

CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:L

Learn more about CVSS

Weakness

  • CWE-79: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')

Source file

maven/org.apache.felix/org.apache.felix.http.webconsoleplugin/CVE-2025-27867.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:00 +0000.