Advisory Database
  • Advisories
  • Dependency Scanning
  1. maven
  2. ›
  3. org.apache.dubbo/dubbo
  4. ›
  5. CVE-2023-29234

CVE-2023-29234: Bypass serialize checks in Apache Dubbo

December 15, 2023 (updated February 13, 2025)

A deserialization vulnerability existed when decode a malicious package.This issue affects Apache Dubbo: from 3.1.0 through 3.1.10, from 3.2.0 through 3.2.4.

Users are recommended to upgrade to the latest version, which fixes the issue.

References

  • github.com/advisories/GHSA-6x49-w35h-wqrj
  • github.com/apache/dubbo
  • lists.apache.org/thread/wb2df2whkdnbgp54nnqn0m94rllx8f77
  • nvd.nist.gov/vuln/detail/CVE-2023-29234

Code Behaviors & Features

Detect and mitigate CVE-2023-29234 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions starting from 3.1.0 before 3.1.11, all versions starting from 3.2.0 before 3.2.5

Fixed versions

  • 3.1.11
  • 3.2.5

Solution

Upgrade to versions 3.1.11, 3.2.5 or above.

Impact 9.8 CRITICAL

CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Learn more about CVSS

Weakness

  • CWE-502: Deserialization of Untrusted Data

Source file

maven/org.apache.dubbo/dubbo/CVE-2023-29234.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:01 +0000.