Advisory Database
  • Advisories
  • Dependency Scanning
  1. maven
  2. ›
  3. org.apache.commons/commons-configuration2
  4. ›
  5. CVE-2026-45205

CVE-2026-45205: Apache Commons Configuration: StackOverflowError for YAML input with cycles

May 14, 2026 (updated May 20, 2026)

Uncontrolled Recursion vulnerability in Apache Commons.

When processing an untrusted configuration file, Commons Configuration will throw a StackOverflowError for YAML input with cycles. This issue affects Apache Commons: from 2.2 before 2.15.0.

Users are recommended to upgrade to version 2.15.0, which fixes the issue.

References

  • github.com/advisories/GHSA-337m-mw94-2v6g
  • github.com/apache/commons-configuration/pull/634
  • lists.apache.org/thread/q3q3j10ohcqhs6o0rg1v7kz6kk27vtkk
  • nvd.nist.gov/vuln/detail/CVE-2026-45205

Code Behaviors & Features

Detect and mitigate CVE-2026-45205 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions starting from 2.2.0 before 2.15.0

Fixed versions

  • 2.15.0

Solution

Upgrade to version 2.15.0 or above.

Impact 5.3 MEDIUM

CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L

Learn more about CVSS

Weakness

  • CWE-674: Uncontrolled Recursion

Source file

maven/org.apache.commons/commons-configuration2/CVE-2026-45205.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:06 +0000.