Advisory Database
  • Advisories
  • Dependency Scanning
  1. maven
  2. ›
  3. org.apache.cassandra/cassandra-all
  4. ›
  5. CVE-2026-27314

CVE-2026-27314: Apache Cassandra is vulnerable to privilege escalation in an mTLS environment using MutualTlsAuthenticator

April 7, 2026 (updated April 8, 2026)

Privilege escalation in Apache Cassandra 5.0 on an mTLS environment using MutualTlsAuthenticator allows a user with only CREATE permission to associate their own certificate identity with an arbitrary role, including a superuser role, and authenticate as that role via ADD IDENTITY.

Users are recommended to upgrade to version 5.0.7+, which fixes this issue.

References

  • github.com/advisories/GHSA-qxpc-96fq-wwmg
  • github.com/apache/cassandra
  • github.com/apache/cassandra/commit/b584a435970e5125e1def5148d943c39569dc7af
  • github.com/apache/cassandra/releases/tag/cassandra-5.0.7
  • lists.apache.org/thread/zrng82ddy4rpsmfyk582v6hqxcqrbz7f
  • nvd.nist.gov/vuln/detail/CVE-2026-27314

Code Behaviors & Features

Detect and mitigate CVE-2026-27314 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions starting from 5.0-alpha1 before 5.0.7

Fixed versions

  • 5.0.7

Solution

Upgrade to version 5.0.7 or above.

Impact 8.8 HIGH

CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Learn more about CVSS

Weakness

  • CWE-267: Privilege Defined With Unsafe Actions

Source file

maven/org.apache.cassandra/cassandra-all/CVE-2026-27314.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:25 +0000.