CVE-2026-49042: Apache Camel-Langchain4j-Tools: Tool argument headers are not filtered against declared parameters
(updated )
Improper Input Validation vulnerability in Apache Camel.
This issue affects Apache Camel: from 4.8.0 through 4.18.2, from 4.19.0 through 4.20.0.
Users are recommended to upgrade to version 4.18.3, 4.21.0, which fixes the issue.
References
- camel.apache.org/security/CVE-2026-49042.html
- github.com/advisories/GHSA-hh8r-75r6-qrg9
- github.com/apache/camel/commit/5d0028f6bc7a70556dc1d408b1b6cadb59e1842d
- github.com/apache/camel/commit/6851a94075b82375381a7236e081292b67f6bf9a
- github.com/apache/camel/commit/e9c4541a91ce75ce4817d499e704299c3933edaa
- github.com/apache/camel/pull/23535
- github.com/apache/camel/pull/23551
- github.com/apache/camel/releases/tag/camel-4.18.3
- github.com/apache/camel/releases/tag/camel-4.21.0
- issues.apache.org/jira/browse/CAMEL-23621
- nvd.nist.gov/vuln/detail/CVE-2026-49042
Code Behaviors & Features
Detect and mitigate CVE-2026-49042 with GitLab Dependency Scanning
Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →