Advisory Database
  • Advisories
  • Dependency Scanning
  1. maven
  2. ›
  3. org.apache.artemis/artemis-stomp-protocol
  4. ›
  5. CVE-2026-40914

CVE-2026-40914: Apache Artemis has an Incorrect Authorization issue

May 28, 2026 (updated July 2, 2026)

A vulnerability exists in Apache Artemis whereby an application using the STOMP protocol with security credentials that grant either the consume or send permission on an address can augment the routing-type supported by that address even if said user doesn’t have the createAddress permission for that particular address. A user could successfully send a message to an address or consume a message from a queue with a routing-type not supported by the corresponding address when that operation should actually be rejected on the basis that the user doesn’t have permission to change the routing-type of the address. Even though the user was already granted permission to send and/or consume messages, they should not be able to augment the routing-type of the address without the createAddress permission.

This issue affects Apache Artemis: from 2.50.0 through 2.53.0; Apache ActiveMQ Artemis: from 2.0.0 through 2.44.0.

Users are recommended to upgrade to version 2.54.0, which fixes the issue.

References

  • github.com/advisories/GHSA-rf99-f9j2-gv3f
  • github.com/apache/artemis/commit/53173375c4d5e4b57890e89d37ed8b666c974474
  • github.com/apache/artemis/pull/6395
  • issues.apache.org/jira/browse/ARTEMIS-5996
  • lists.apache.org/thread/6q3st8dlorz2q05svqn11k1xl7jkmm4c
  • nvd.nist.gov/vuln/detail/CVE-2026-40914

Code Behaviors & Features

Detect and mitigate CVE-2026-40914 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions starting from 2.0.0 up to 2.44.0, all versions starting from 2.50.0 before 2.54.0

Fixed versions

  • 2.54.0

Solution

Upgrade to version 2.54.0 or above.

Impact 4.3 MEDIUM

CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N

Learn more about CVSS

Weakness

  • CWE-863: Incorrect Authorization

Source file

maven/org.apache.artemis/artemis-stomp-protocol/CVE-2026-40914.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:15:43 +0000.