CVE-2026-49877: Apache ActiveMQ Improper Authorization vulnerability
(updated )
Improper Authorization vulnerability in Apache ActiveMQ.
An authenticated low-privilege Web Console user by default can access /admin/* paths in the Web Console. The default Jetty settings incorrectly did not limit those paths to only admins. This issue affects Apache ActiveMQ: before 5.19.8, from 6.0.0 before 6.2.7.
Users are recommended to upgrade to version 6.2.7 or 5.19.8, which fixes the issue.
References
- github.com/advisories/GHSA-f892-4h9f-j7g9
- github.com/apache/activemq/commit/085efea55270aca20f2158c0a91a0f4a9fe497f4
- github.com/apache/activemq/commit/1eda6a164f38b6eb1a90ffb1462a95cd9ad121e9
- github.com/apache/activemq/commit/be70a7efa1efcb6bdb9988f736245b06d39a91e4
- github.com/apache/activemq/pull/2074
- github.com/apache/activemq/releases/tag/activemq-5.19.8
- github.com/apache/activemq/releases/tag/activemq-6.2.7
- lists.apache.org/thread/w82vtc3q02j5ot94tnyy1197y3wb98hl
- nvd.nist.gov/vuln/detail/CVE-2026-49877
Code Behaviors & Features
Detect and mitigate CVE-2026-49877 with GitLab Dependency Scanning
Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →