CVE-2026-49432: Apache ActiveMQ, Apache ActiveMQ All, Apache ActiveMQ Stomp has an Improper Input Validation vulnerability
(updated )
Improper Input Validation vulnerability in Apache ActiveMQ, Apache ActiveMQ All, Apache ActiveMQ Stomp.
A remote unauthenticated peer that can reach an exposed STOMP connector can trigger denial-of-service behavior by sending a negative content-length. For the NIO STOMP transport, an attacker can keep streaming body bytes and grow the per-connection command buffer beyond configured limits to cause OOM. For the blocking STOMP protocol, an error will instead force abnormal transport exception handling for the affected connection and closure. This issue affects Apache ActiveMQ: before 5.19.8, from 6.0.0 before 6.2.7; Apache ActiveMQ All: before 5.19.8, from 6.0.0 before 6.2.7; Apache ActiveMQ Stomp: before 5.19.8, from 6.0.0 before 6.2.7.
Users are recommended to upgrade to version 6.2.7 or 5.19.8, which fixes the issue.
References
- github.com/advisories/GHSA-xjwq-9jw5-jf7w
- github.com/apache/activemq/commit/1493db95b5918d4f4a305fd1df8155f57c38850b
- github.com/apache/activemq/commit/63ca7332a47239964cbf2e343603412254ebb358
- github.com/apache/activemq/commit/713cae920329c4caea016b08300182ec5c6dc99b
- github.com/apache/activemq/pull/2064
- github.com/apache/activemq/releases/tag/activemq-5.19.8
- github.com/apache/activemq/releases/tag/activemq-6.2.7
- lists.apache.org/thread/fsjb26605syqr8xks249h8gkp86t55d2
- nvd.nist.gov/vuln/detail/CVE-2026-49432
Code Behaviors & Features
Detect and mitigate CVE-2026-49432 with GitLab Dependency Scanning
Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →