Advisory Database
  • Advisories
  • Dependency Scanning
  1. maven
  2. ›
  3. org.apache.activemq/activemq-broker
  4. ›
  5. CVE-2026-49434

CVE-2026-49434: Apache ActiveMQ Broker, Apache ActiveMQ, Apache ActiveMQ All have an Improper Input Validation vulnerability

June 30, 2026 (updated November 4, 2026)

Improper Input Validation vulnerability in Apache ActiveMQ Broker, Apache ActiveMQ, Apache ActiveMQ All.

An attacker that has access to publish or modify entries in LDAP that match the configured searchBase and searchFilter can instantiate denied transports inside the broker JVM. This can be used to fetch an attacker URL and spawn a second BrokerService inside the same JVM. This issue affects Apache ActiveMQ Broker: before 5.19.8, from 6.0.0 before 6.2.7; Apache ActiveMQ: before 5.19.8, from 6.0.0 before 6.2.7; Apache ActiveMQ All: before 5.19.8, from 6.0.0 before 6.2.7.

Users are recommended to upgrade to version 6.2.7 or 5.19.8, which fixes the issue.

References

  • github.com/advisories/GHSA-h5gm-rvw6-2xpx
  • github.com/apache/activemq/commit/0927bcb99e18c517728898be9f125589653ee899
  • github.com/apache/activemq/commit/ac3d06454bdf8b21db7ef419f42d17ab124a6008
  • github.com/apache/activemq/commit/f055bcc1dcd4a4a76b731fef43829fff515a7fbf
  • github.com/apache/activemq/pull/2077
  • github.com/apache/activemq/releases/tag/activemq-5.19.8
  • github.com/apache/activemq/releases/tag/activemq-6.2.7
  • lists.apache.org/thread/hcjh7kdk4l85tb9ksmvcnkhso1ngj50o
  • nvd.nist.gov/vuln/detail/CVE-2026-49434

Code Behaviors & Features

Detect and mitigate CVE-2026-49434 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 5.19.8, all versions starting from 6.0.0 before 6.2.7

Fixed versions

  • 5.19.8
  • 6.2.7

Solution

Upgrade to versions 5.19.8, 6.2.7 or above.

Impact 7.5 HIGH

CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N

Learn more about CVSS

Weakness

  • CWE-20: Improper Input Validation

Source file

maven/org.apache.activemq/activemq-broker/CVE-2026-49434.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:15:53 +0000.