Advisory Database
  • Advisories
  • Dependency Scanning
  1. maven
  2. ›
  3. org.apache.accumulo/accumulo-shell
  4. ›
  5. CVE-2023-34340

CVE-2023-34340: Apache Accumulo Improper Authentication vulnerability

June 21, 2023 (updated October 9, 2024)

Improper Authentication vulnerability in Apache Software Foundation Apache Accumulo. This issue affects Apache Accumulo: 2.1.0.

Accumulo 2.1.0 contains a defect in the user authentication process that may succeed when invalid credentials are provided. Users are advised to upgrade to 2.1.1.

References

  • accumulo.apache.org/release/accumulo-2.1.1
  • github.com/advisories/GHSA-hp5w-w29m-vg63
  • github.com/apache/accumulo
  • github.com/apache/accumulo/commit/0f2389735fd32e0bbc93ecde5d8c814b275b21b5
  • github.com/apache/accumulo/issues/3427
  • github.com/apache/accumulo/issues/3433
  • github.com/apache/accumulo/pull/3440
  • lists.apache.org/thread/syy6jftvy9l6tlhn33o0rzwhh4rd0z4t
  • nvd.nist.gov/vuln/detail/CVE-2023-34340

Code Behaviors & Features

Detect and mitigate CVE-2023-34340 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions starting from 2.1.0 before 2.1.1, version 2.1.0

Fixed versions

  • 2.1.1

Solution

Upgrade to version 2.1.1 or above.

Impact 9.8 CRITICAL

CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Learn more about CVSS

Weakness

  • CWE-287: Improper Authentication

Source file

maven/org.apache.accumulo/accumulo-shell/CVE-2023-34340.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:17:08 +0000.