Advisory Database
  • Advisories
  • Dependency Scanning
  1. maven
  2. ›
  3. net.snowflake/snowflake-jdbc
  4. ›
  5. CVE-2025-24790

CVE-2025-24790: Snowflake JDBC uses insecure temporary credential cache file permissions

January 29, 2025

Issue

Snowflake discovered and remediated a vulnerability in the Snowflake JDBC Driver. On Linux systems, when temporary credential caching is enabled, the Snowflake JDBC Driver will cache temporary credentials locally in a world-readable file.

This vulnerability affects versions 3.6.8 through 3.21.0. Snowflake fixed the issue in version 3.22.0.

Vulnerability Details

On Linux, when either EXTERNALBROWSER or USERNAME_PASSWORD_MFA authentication methods are used with temporary credential caching enabled, the Snowflake JDBC Driver will cache temporary credentials in a local file. In the vulnerable versions of the Driver, this file is created with world-readable permissions.

Solution

Snowflake released version 3.22.0 of the Snowflake JDBC Driver, which fixes this issue. We recommend users upgrade to version 3.22.0.

Additional Information

If you discover a security vulnerability in one of our products or websites, please report the issue to HackerOne. For more information, please see our Vulnerability Disclosure Policy.

References

  • github.com/advisories/GHSA-33g6-495w-v8j2
  • github.com/snowflakedb/snowflake-jdbc
  • github.com/snowflakedb/snowflake-jdbc/commit/9e1a5acf12406b16c4780ca013f4c4db48b74b59
  • github.com/snowflakedb/snowflake-jdbc/security/advisories/GHSA-33g6-495w-v8j2
  • nvd.nist.gov/vuln/detail/CVE-2025-24790

Code Behaviors & Features

Detect and mitigate CVE-2025-24790 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions starting from 3.6.8 before 3.22.0

Fixed versions

  • 3.22.0

Solution

Upgrade to version 3.22.0 or above.

Impact 4.4 MEDIUM

CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:N

Learn more about CVSS

Weakness

  • CWE-276: Incorrect Default Permissions

Source file

maven/net.snowflake/snowflake-jdbc/CVE-2025-24790.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:15:55 +0000.