Advisory Database
  • Advisories
  • Dependency Scanning
  1. maven
  2. ›
  3. io.swagger/swagger-codegen
  4. ›
  5. CVE-2017-1000208

CVE-2017-1000208: Deserialization of Untrusted Data

October 19, 2018 (updated September 16, 2021)

A vulnerability in Swagger-Parser’s (version <= 1.0.30) yaml parsing functionality results in arbitrary code being executed when a maliciously crafted yaml Open-API specification is parsed. This in particular, affects the ‘generate’ and ‘validate’ command in swagger-codegen (<= 2.2.2) and can lead to arbitrary code being executed when these commands are used on a well-crafted yaml specification.

References

  • github.com/advisories/GHSA-q7pf-qr96-2vq5
  • github.com/swagger-api/swagger-parser/releases/tag/v1.0.31
  • nvd.nist.gov/vuln/detail/CVE-2017-1000208

Code Behaviors & Features

Detect and mitigate CVE-2017-1000208 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 2.2.3

Fixed versions

  • 2.2.3

Solution

Upgrade to version 2.2.3 or above.

Impact 8.8 HIGH

CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

Learn more about CVSS

Weakness

  • CWE-502: Deserialization of Untrusted Data
  • CWE-78: Improper Neutralization of Special Elements used in an OS Command ('OS Command Injection')

Source file

maven/io.swagger/swagger-codegen/CVE-2017-1000208.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:04 +0000.