Advisory Database
  • Advisories
  • Dependency Scanning
  1. maven
  2. ›
  3. io.projectreactor.netty/reactor-netty-http
  4. ›
  5. CVE-2020-5404

CVE-2020-5404: Insufficiently Protected Credentials

February 10, 2022

The HttpClient from Reactor Netty,, may be used incorrectly, leading to a credentials leak during a redirect to a different domain. In order for this to happen, the HttpClient must have been explicitly configured to follow redirects.

References

  • github.com/advisories/GHSA-gpch-h32j-gx6x
  • nvd.nist.gov/vuln/detail/CVE-2020-5404
  • pivotal.io/security/cve-2020-5404

Code Behaviors & Features

Detect and mitigate CVE-2020-5404 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions starting from 0.8.0 before 0.8.16, all versions starting from 0.9.0 before 0.9.5

Fixed versions

  • 0.9.5

Solution

Upgrade to versions 0.9.5, 0.9.5 or above.

Impact 5.9 MEDIUM

CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:L/A:N

Learn more about CVSS

Weakness

  • CWE-522: Insufficiently Protected Credentials

Source file

maven/io.projectreactor.netty/reactor-netty-http/CVE-2020-5404.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:10 +0000.