Advisory Database
  • Advisories
  • Dependency Scanning
  1. maven
  2. ›
  3. io.netty/netty-codec-http
  4. ›
  5. CVE-2026-59898

CVE-2026-59898: Netty: WebSockets V07/V08 handshaker missing Connection/Upgrade validation

July 22, 2026

An attacker can force WebSocket upgrade via the lax V07 (or V08) handshaker by sending Sec-WebSocket-Version: 7 and omitting Connection: Upgrade / Upgrade: websocket headers, completing a protocol switch that a proxy would not recognize as an Upgrade request and enabling HTTP request smuggling / protocol-confusion attacks.

References

  • github.com/advisories/GHSA-4mp9-239f-g9hg
  • github.com/netty/netty/releases/tag/netty-4.1.136.Final
  • github.com/netty/netty/releases/tag/netty-4.2.16.Final
  • github.com/netty/netty/security/advisories/GHSA-4mp9-239f-g9hg
  • nvd.nist.gov/vuln/detail/CVE-2026-59898

Code Behaviors & Features

Detect and mitigate CVE-2026-59898 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 4.1.136, all versions starting from 4.2.0 before 4.2.16

Fixed versions

  • 4.1.136
  • 4.2.16

Solution

Upgrade to versions 4.1.136, 4.2.16 or above.

Impact 4.8 MEDIUM

CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:N

Learn more about CVSS

Weakness

  • CWE-444: Inconsistent Interpretation of HTTP Requests ('HTTP Request/Response Smuggling')

Source file

maven/io.netty/netty-codec-http/CVE-2026-59898.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:41 +0000.