Advisory Database
  • Advisories
  • Dependency Scanning
  1. maven
  2. ›
  3. io.netty/netty-codec-http
  4. ›
  5. CVE-2026-42585

CVE-2026-42585: Netty vulnerable to HTTP Request Smuggling due to malformed Transfer-Encoding

May 7, 2026 (updated May 14, 2026)

Netty incorrectly parses malformed Transfer-Encoding, enabling request smuggling attacks.

References

  • datatracker.ietf.org/doc/html/rfc9112
  • github.com/advisories/GHSA-38f8-5428-x5cv
  • github.com/netty/netty/security/advisories/GHSA-38f8-5428-x5cv
  • nvd.nist.gov/vuln/detail/CVE-2026-42585

Code Behaviors & Features

Detect and mitigate CVE-2026-42585 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 4.1.133, all versions starting from 4.2.0-Alpha.1 before 4.2.13

Fixed versions

  • 4.1.133
  • 4.2.13

Solution

Upgrade to versions 4.1.133, 4.2.13 or above.

Impact 6.5 MEDIUM

CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N

Learn more about CVSS

Weakness

  • CWE-444: Inconsistent Interpretation of HTTP Requests ('HTTP Request/Response Smuggling')

Source file

maven/io.netty/netty-codec-http/CVE-2026-42585.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:17:13 +0000.