Advisory Database
  • Advisories
  • Dependency Scanning
  1. maven
  2. ›
  3. io.netty/netty-codec-compression
  4. ›
  5. CVE-2025-58057

CVE-2025-58057: Netty's decoders vulnerable to DoS via zip bomb style attack

September 3, 2025 (updated November 10, 2025)

With specially crafted input, BrotliDecoder and some other decompressing decoders will allocate a large number of reachable byte buffers, which can lead to denial of service.

References

  • github.com/advisories/GHSA-3p8m-j85q-pgmj
  • github.com/netty/netty
  • github.com/netty/netty/commit/9d804c54ce962408ae6418255a83a13924f7145d
  • github.com/netty/netty/security/advisories/GHSA-3p8m-j85q-pgmj
  • nvd.nist.gov/vuln/detail/CVE-2025-58057

Code Behaviors & Features

Detect and mitigate CVE-2025-58057 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions starting from 4.2.0.Alpha1 before 4.2.5.Final

Fixed versions

  • 4.2.5.Final

Solution

Upgrade to version 4.2.5.Final or above.

Impact 7.5 HIGH

CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Learn more about CVSS

Weakness

  • CWE-409: Improper Handling of Highly Compressed Data (Data Amplification)

Source file

maven/io.netty/netty-codec-compression/CVE-2025-58057.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:01 +0000.