Advisory Database
  • Advisories
  • Dependency Scanning
  1. maven
  2. ›
  3. io.jenkins/configuration-as-code
  4. ›
  5. CVE-2018-1000610

CVE-2018-1000610: Insufficiently Protected Credentials

June 26, 2018 (updated October 3, 2019)

A vulnerability exists in the Jenkins Configuration as Code Plugin that allows attackers with access to Jenkins log files

References

  • jenkins.io/security/advisory/2018-06-25/
  • nvd.nist.gov/vuln/detail/CVE-2018-1000610

Code Behaviors & Features

Detect and mitigate CVE-2018-1000610 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions starting from 0.1 up to 0.7

Fixed versions

  • 0.8

Solution

Upgrade to version 0.8 or above.

Impact 8.8 HIGH

CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Learn more about CVSS

Weakness

  • CWE-522: Insufficiently Protected Credentials

Source file

maven/io.jenkins/configuration-as-code/CVE-2018-1000610.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:11 +0000.