Advisory Database
  • Advisories
  • Dependency Scanning
  1. maven
  2. ›
  3. io.jenkins.plugins/simple-queue
  4. ›
  5. CVE-2024-54003

CVE-2024-54003: Jenkins Simple Queue Plugin has stored cross-site scripting (XSS) vulnerability

November 27, 2024

Jenkins Simple Queue Plugin 1.4.4 and earlier does not escape the view name.

This results in a stored cross-site scripting (XSS) vulnerability exploitable by attackers with View/Create permission.

Simple Queue Plugin 1.4.5 escapes the view name.

References

  • github.com/advisories/GHSA-4gwv-fpmg-cmv2
  • nvd.nist.gov/vuln/detail/CVE-2024-54003
  • www.jenkins.io/security/advisory/2024-11-27/

Code Behaviors & Features

Detect and mitigate CVE-2024-54003 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 1.4.5

Fixed versions

  • 1.4.5

Solution

Upgrade to version 1.4.5 or above.

Impact 8 HIGH

CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:H

Learn more about CVSS

Weakness

  • CWE-79: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')

Source file

maven/io.jenkins.plugins/simple-queue/CVE-2024-54003.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:05 +0000.