Advisory Database
  • Advisories
  • Dependency Scanning
  1. maven
  2. ›
  3. io.jenkins.plugins/coverage
  4. ›
  5. CVE-2025-67641

CVE-2025-67641: Jenkins Coverage Plugin has a stored cross-site scripting (XSS) vulnerability

December 10, 2025

Jenkins Coverage Plugin 2.3054.ve1ff7b_a_a_123b_ and earlier does not validate the configured coverage results ID when creating coverage results, only when submitting the job configuration through the UI, allowing attackers with Item/Configure permission to use a javascript: scheme URL as identifier by configuring the job through the REST API, resulting in a stored cross-site scripting (XSS) vulnerability.

References

  • github.com/advisories/GHSA-v3f3-rf6r-43x5
  • github.com/jenkinsci/coverage-plugin
  • github.com/jenkinsci/coverage-plugin/commit/1dfe888b02499d39185397862cf2790efc03e955
  • nvd.nist.gov/vuln/detail/CVE-2025-67641
  • www.jenkins.io/security/advisory/2025-12-10/

Code Behaviors & Features

Detect and mitigate CVE-2025-67641 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 2.3056

Fixed versions

  • 2.3056

Solution

Upgrade to version 2.3056 or above.

Impact 8 HIGH

CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:H

Learn more about CVSS

Weakness

  • CWE-79: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')

Source file

maven/io.jenkins.plugins/coverage/CVE-2025-67641.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:15:27 +0000.