Advisory Database
  • Advisories
  • Dependency Scanning
  1. maven
  2. ›
  3. io.jenkins.plugins/autonomiq
  4. ›
  5. CVE-2022-25194

CVE-2022-25194: Cross-Site Request Forgery (CSRF)

February 16, 2022 (updated May 4, 2022)

A cross-site request forgery (CSRF) vulnerability in Jenkins autonomiq Plugin 1.15 and earlier allows attackers to connect to an attacker-specified URL server using attacker-specified credentials.

References

  • github.com/advisories/GHSA-g5wh-fw4m-2v28
  • github.com/jenkinsci/autonomiq-plugin/commit/e06b1ff67664a90819c9561bbc12f4c6e593d1dc
  • nvd.nist.gov/vuln/detail/CVE-2022-25194
  • www.jenkins.io/security/advisory/2022-02-15/

Code Behaviors & Features

Detect and mitigate CVE-2022-25194 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 1.16

Fixed versions

  • 1.16

Solution

Upgrade to version 1.16 or above.

Impact 8.8 HIGH

CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

Learn more about CVSS

Weakness

  • CWE-352: Cross-Site Request Forgery (CSRF)
  • CWE-352: Cross-Site Request Forgery (CSRF)

Source file

maven/io.jenkins.plugins/autonomiq/CVE-2022-25194.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:33 +0000.