Advisory Database
  • Advisories
  • Dependency Scanning
  1. maven
  2. ›
  3. io.dataease/dataease-plugin-common
  4. ›
  5. CVE-2022-34112

CVE-2022-34112: Dataease before 1.11.2 access control issue allows attackers to arbitrarily uninstall plugin

July 23, 2022 (updated July 27, 2022)

An access control issue in the component /api/plugin/uninstall Dataease v1.11.1 allows attackers to arbitrarily uninstall the plugin, a right normally reserved for the administrator.

References

  • github.com/advisories/GHSA-c2pj-rr68-pw94
  • github.com/dataease/dataease/commit/5f611d3e3934816e9ad34e3d21807978001e2c8b
  • github.com/dataease/dataease/issues/2429
  • github.com/dataease/dataease/releases/tag/v1.11.2
  • nvd.nist.gov/vuln/detail/CVE-2022-34112

Code Behaviors & Features

Detect and mitigate CVE-2022-34112 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions up to 1.11.1

Fixed versions

  • 1.11.2

Solution

Upgrade to version 1.11.2 or above.

Impact 6.5 MEDIUM

CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N

Learn more about CVSS

Source file

maven/io.dataease/dataease-plugin-common/CVE-2022-34112.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:10 +0000.