Advisory Database
  • Advisories
  • Dependency Scanning
  1. maven
  2. ›
  3. de.eacg/ecs-publisher
  4. ›
  5. CVE-2019-1003045

CVE-2019-1003045: Insufficiently Protected Credentials

May 13, 2022 (updated January 30, 2024)

A vulnerability in Jenkins ECS Publisher Plugin 1.0.0 and earlier allows attackers with Item/Extended Read permission, or local file system access to the Jenkins home directory to obtain the API token configured in this plugin’s configuration.

References

  • www.openwall.com/lists/oss-security/2019/03/28/2
  • www.securityfocus.com/bid/107628
  • github.com/advisories/GHSA-ffj8-w4rj-vr7v
  • jenkins.io/security/advisory/2019-03-25/
  • nvd.nist.gov/vuln/detail/CVE-2019-1003045

Code Behaviors & Features

Detect and mitigate CVE-2019-1003045 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions up to 1.0.0

Fixed versions

  • 1.0.1

Solution

Upgrade to version 1.0.1 or above.

Impact 6.5 MEDIUM

CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N

Learn more about CVSS

Weakness

  • CWE-522: Insufficiently Protected Credentials

Source file

maven/de.eacg/ecs-publisher/CVE-2019-1003045.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:15 +0000.