Advisory Database
  • Advisories
  • Dependency Scanning
  1. maven
  2. ›
  3. com.typesafe.play/play-ws_2.12
  4. ›
  5. CVE-2019-17598

CVE-2019-17598: Insufficiently Protected Credentials

November 5, 2019 (updated November 15, 2019)

An issue was discovered in Lightbend Play Framework. When configured to make requests using an authenticated HTTP proxy, play-ws may sometimes, typically under high load, when connecting to a target host using https, expose the proxy credentials to the target host.

References

  • nvd.nist.gov/vuln/detail/CVE-2019-17598
  • www.playframework.com/security/vulnerability
  • www.playframework.com/security/vulnerability/CVE-2019-17598-PlayWSHttpConnectAuthorizationHeaders

Code Behaviors & Features

Detect and mitigate CVE-2019-17598 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions starting from 2.5.0 up to 2.6.23

Fixed versions

  • 2.6.24

Solution

Upgrade to version 2.6.24 or above.

Impact 7.5 HIGH

CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N

Learn more about CVSS

Weakness

  • CWE-326: Inadequate Encryption Strength

Source file

maven/com.typesafe.play/play-ws_2.12/CVE-2019-17598.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:17:25 +0000.