Advisory Database
  • Advisories
  • Dependency Scanning
  1. maven
  2. ›
  3. com.shopizer/shopizer
  4. ›
  5. CVE-2022-23059

CVE-2022-23059: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')

March 29, 2022 (updated April 8, 2022)

A Stored Cross Site Scripting (XSS) vulnerability exists in Shopizer versions v2.0.2 through v2.17.0 via the “Manage Images” tab, which allows an attacker to upload a SVG file containing malicious JavaScript code.

References

  • github.com/shopizer-ecommerce/shopizer/commit/6b9f1ecd303b3b724d96bd08095c1a751dcc287e
  • nvd.nist.gov/vuln/detail/CVE-2022-23059
  • www.whitesourcesoftware.com/vulnerability-database/CVE-2022-23059

Code Behaviors & Features

Detect and mitigate CVE-2022-23059 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions starting from 2.0.2 up to 2.17.0

Fixed versions

  • 3.0.0

Solution

Upgrade to version 3.0.0 or above.

Impact 4.8 MEDIUM

CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:L/I:L/A:N

Learn more about CVSS

Weakness

  • CWE-79: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')

Source file

maven/com.shopizer/shopizer/CVE-2022-23059.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:54 +0000.