Advisory Database
  • Advisories
  • Dependency Scanning
  1. maven
  2. ›
  3. com.rabbitmq/amqp-client
  4. ›
  5. CVE-2018-11087

CVE-2018-11087: Improper Certificate Validation

October 18, 2018 (updated September 20, 2021)

Pivotal Spring AMQP, 1.x versions prior to 1.7.10 and 2.x versions prior to 2.0.6, expose a man-in-the-middle vulnerability due to lack of hostname validation. A malicious user that has the ability to intercept traffic would be able to view data in transit.

References

  • github.com/advisories/GHSA-w4g2-9hj6-5472
  • nvd.nist.gov/vuln/detail/CVE-2018-11087
  • pivotal.io/security/cve-2018-11087

Code Behaviors & Features

Detect and mitigate CVE-2018-11087 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 4.8.0, all versions starting from 5.0.0 before 5.4.0

Fixed versions

  • 4.8.0
  • 5.4.0

Solution

Upgrade to versions 4.8.0, 5.4.0 or above.

Impact 5.9 MEDIUM

CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N

Learn more about CVSS

Weakness

  • CWE-295: Improper Certificate Validation

Source file

maven/com.rabbitmq/amqp-client/CVE-2018-11087.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:31 +0000.