Advisory Database
  • Advisories
  • Dependency Scanning
  1. maven
  2. ›
  3. com.paul8620.jenkins.plugins/pipeline-aggregator-view
  4. ›
  5. CVE-2019-16564

CVE-2019-16564: Cross-site Scripting

December 17, 2019 (updated December 18, 2019)

Jenkins Pipeline Aggregator View Plugin does not escape information shown on its view, resulting in a stored XSS vulnerability exploitable by attackers able to affects view content such as job display name or pipeline stage names.

References

  • jenkins.io/security/advisory/2019-12-17/
  • nvd.nist.gov/vuln/detail/CVE-2019-16564

Code Behaviors & Features

Detect and mitigate CVE-2019-16564 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions up to 1.8

Fixed versions

  • 1.9

Solution

Upgrade to version 1.9 or above.

Impact 5.4 MEDIUM

CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N

Learn more about CVSS

Weakness

  • CWE-79: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')

Source file

maven/com.paul8620.jenkins.plugins/pipeline-aggregator-view/CVE-2019-16564.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:15:20 +0000.