Advisory Database
  • Advisories
  • Dependency Scanning
  1. maven
  2. ›
  3. com.mabl.integration.jenkins/mabl-integration
  4. ›
  5. CVE-2023-37951

CVE-2023-37951: Insufficiently Protected Credentials

July 12, 2023 (updated July 20, 2023)

Jenkins mabl Plugin 0.0.46 and earlier does not set the appropriate context for credentials lookup, allowing attackers with Item/Configure permission to access and capture credentials they are not entitled to.

References

  • www.openwall.com/lists/oss-security/2023/07/12/2
  • github.com/advisories/GHSA-4c3q-r84r-q6pp
  • nvd.nist.gov/vuln/detail/CVE-2023-37951
  • www.jenkins.io/security/advisory/2023-07-12/

Code Behaviors & Features

Detect and mitigate CVE-2023-37951 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 0.0.47

Fixed versions

  • 0.0.47

Solution

Upgrade to version 0.0.47 or above.

Impact 6.5 MEDIUM

CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N

Learn more about CVSS

Weakness

  • CWE-522: Insufficiently Protected Credentials

Source file

maven/com.mabl.integration.jenkins/mabl-integration/CVE-2023-37951.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:15:40 +0000.