Advisory Database
  • Advisories
  • Dependency Scanning
  1. maven
  2. ›
  3. com.liferay/com.liferay.portal.search
  4. ›
  5. CVE-2025-43804

CVE-2025-43804: Liferay search widget vulnerable to Cross-site Scripting

September 17, 2025 (updated November 10, 2025)

There is a Cross-site scripting (XSS) vulnerability in Liferay Portal’s Search widget . Versions 7.4.3.93 through 7.4.3.111, and Liferay DXP 2023.Q4.0, 2023.Q3.1 through 2023.Q3.4 allow remote attackers to inject arbitrary web scripts or HTML via the _com_liferay_portal_search_web_portlet_SearchPortlet_userId parameter.

References

  • github.com/advisories/GHSA-ccrc-5vp5-vp5j
  • liferay.dev/portal/security/known-vulnerabilities/-/asset_publisher/jekt/content/CVE-2025-43804
  • nvd.nist.gov/vuln/detail/CVE-2025-43804

Code Behaviors & Features

Detect and mitigate CVE-2025-43804 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 8.0.93

Fixed versions

  • 8.0.93

Solution

Upgrade to version 8.0.93 or above.

Impact 5.4 MEDIUM

CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:N

Learn more about CVSS

Weakness

  • CWE-79: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')

Source file

maven/com.liferay/com.liferay.portal.search/CVE-2025-43804.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:14 +0000.