Advisory Database
  • Advisories
  • Dependency Scanning
  1. maven
  2. ›
  3. com.intuit.karate/karate-core
  4. ›
  5. GHSA-5x5q-8cgm-2hjq

GHSA-5x5q-8cgm-2hjq: Karate has vulnerable dependency on json-smart package (CVE-2023-1370)

March 31, 2023 (updated January 7, 2025)

The CVE

Click to open external image

References

  • github.com/advisories/GHSA-5x5q-8cgm-2hjq
  • github.com/karatelabs/karate
  • github.com/karatelabs/karate/security/advisories/GHSA-5x5q-8cgm-2hjq
  • github.com/oswaldobapvicjr/jsonmerge/security/advisories/GHSA-493p-pfq6-5258
  • nvd.nist.gov/vuln/detail/CVE-2023-1370

Code Behaviors & Features

Detect and mitigate GHSA-5x5q-8cgm-2hjq with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions starting from 1.3.1 before 1.4.0, version 1.3.1

Fixed versions

  • 1.4.0

Solution

Upgrade to version 1.4.0 or above.

Impact 7.5 HIGH

CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Learn more about CVSS

Weakness

  • CWE-674: Uncontrolled Recursion

Source file

maven/com.intuit.karate/karate-core/GHSA-5x5q-8cgm-2hjq.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:17:20 +0000.