Advisory Database
  • Advisories
  • Dependency Scanning
  1. maven
  2. ›
  3. com.instaclustr/cassandra-lucene-index-plugin
  4. ›
  5. CVE-2025-26511

CVE-2025-26511: Instaclustr Cassandra-Lucene-Index allows bypass of Cassandra RBAC

February 13, 2025 (updated January 22, 2026)

Summary / Details Systems running the Instaclustr fork of Stratio’s Cassandra-Lucene-Index plugin versions 4.0-rc1-1.0.0 through 4.0.16-1.0.0 and 4.1.0-1.0.0 through 4.1.8-1.0.0, installed into Apache Cassandra version 4.x, are susceptible to a vulnerability which when successfully exploited could allow authenticated Cassandra users to remotely bypass RBAC to access data and and escalate their privileges.

Affected Versions

  • Cassandra-Lucene-Index plugin versions 4.0-rc1-1.0.0 through 4.0.16-1.0.0
  • versions 4.1.0-1.0.0 through 4.1.8-1.0.0 when installed into Apache Cassandra version 4.x.

Required Configuration for Exploit These are the conditions required to enable exploit:

  1. Cassandra 4.x
  2. Vulnerable version of the Cassandra-Lucene-Index plugin configured for use
  3. Data added to tables
  4. Lucene index created
  5. Cassandra flush has run

Mitigation/Prevention Mitigation requires dropping all Lucene indexes and stopping use of the plugin. Exploit will be possible any time the required conditions are met.

Solution Upgrade to a fixed version of the Cassandra-Lucene-Index plugin. Review users in Cassandra to validate all superuser privileges.

References

  • github.com/advisories/GHSA-mrqp-q7vx-v2cx
  • github.com/instaclustr/cassandra-lucene-index
  • github.com/instaclustr/cassandra-lucene-index/commit/44ab4b639c9354a6335f40b1cf6178c745c6e101
  • github.com/instaclustr/cassandra-lucene-index/commit/94380b165bd3e597d3e22e47f8cc674ec7c7bf7f
  • github.com/instaclustr/cassandra-lucene-index/security/advisories/GHSA-mrqp-q7vx-v2cx
  • nvd.nist.gov/vuln/detail/CVE-2025-26511

Code Behaviors & Features

Detect and mitigate CVE-2025-26511 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions starting from 4.0-rc1-1.0.0 before 4.0.17-1.0.0, all versions starting from 4.1.0-1.0.0 before 4.1.8-1.0.1

Fixed versions

  • 4.0.17-1.0.0
  • 4.1.8-1.0.1

Solution

Upgrade to versions 4.0.17-1.0.0, 4.1.8-1.0.1 or above.

Impact 8.8 HIGH

CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Learn more about CVSS

Weakness

  • CWE-288: Authentication Bypass Using an Alternate Path or Channel
  • CWE-863: Incorrect Authorization

Source file

maven/com.instaclustr/cassandra-lucene-index-plugin/CVE-2025-26511.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:43 +0000.