Advisory Database
  • Advisories
  • Dependency Scanning
  1. golang
  2. ›
  3. goauthentik.io
  4. ›
  5. CVE-2024-23647

CVE-2024-23647: Authentik vulnerable to PKCE downgrade attack

January 29, 2024 (updated November 18, 2024)

PKCE is a very important countermeasure in OAuth2 , both for public and confidential clients. It protects against CSRF attacks and code injection attacks. Because of this bug, an attacker can circumvent the protection PKCE offers.

References

  • github.com/advisories/GHSA-mrx3-gxjx-hjqj
  • github.com/goauthentik/authentik
  • github.com/goauthentik/authentik/commit/38e04ae12720e5d81b4f7ac77997eb8d1275d31a
  • github.com/goauthentik/authentik/security/advisories/GHSA-mrx3-gxjx-hjqj
  • nvd.nist.gov/vuln/detail/CVE-2024-23647

Code Behaviors & Features

Detect and mitigate CVE-2024-23647 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 2023.8.7, all versions starting from 2023.10.0 before 2023.10.7

Fixed versions

  • 2023.10.7
  • 2023.8.7

Solution

Upgrade to versions 2023.10.7, 2023.8.7 or above.

Impact 8.8 HIGH

CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

Learn more about CVSS

Weakness

  • CWE-287: Improper Authentication

Source file

go/goauthentik.io/CVE-2024-23647.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:17:23 +0000.