Advisory Database
  • Advisories
  • Dependency Scanning
  1. golang
  2. ›
  3. go.pinniped.dev
  4. ›
  5. CVE-2022-31677

CVE-2022-31677: Pinniped Supervisor Insufficient Session Expiration vulnerability

September 1, 2022

An Insufficient Session Expiration issue was discovered in the Pinniped Supervisor (before v0.19.0). A user authenticating to Kubernetes clusters via the Pinniped Supervisor could potentially use their access token to continue their session beyond what proper use of their refresh token might allow.

References

  • github.com/advisories/GHSA-rp4v-hhm6-rcv9
  • github.com/vmware-tanzu/pinniped/pull/1264
  • github.com/vmware-tanzu/pinniped/releases/tag/v0.19.0
  • github.com/vmware-tanzu/pinniped/security/advisories/GHSA-rp4v-hhm6-rcv9
  • nvd.nist.gov/vuln/detail/CVE-2022-31677

Code Behaviors & Features

Detect and mitigate CVE-2022-31677 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions starting from 0.3.0 before 0.19.0

Fixed versions

  • 0.19.0

Solution

Upgrade to version 0.19.0 or above.

Impact 5.4 MEDIUM

CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:N

Learn more about CVSS

Source file

go/go.pinniped.dev/CVE-2022-31677.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:58 +0000.