Advisory Database
  • Advisories
  • Dependency Scanning
  1. golang
  2. ›
  3. go.etcd.io/etcd/v3
  4. ›
  5. CVE-2018-16886

CVE-2018-16886: Improper Authentication

February 15, 2022 (updated April 12, 2022)

etcd versions 3.2.x before 3.2.26 and 3.3.x before 3.3.11 is vulnerable to an improper authentication issue when role-based access control (RBAC) is used and client-cert-auth is enabled. If an etcd client server TLS certificate contains a Common Name (CN) which matches a valid RBAC username, a remote attacker may authenticate as that user with any valid (trusted) client certificate in a REST API request to the gRPC-gateway.

References

  • www.securityfocus.com/bid/106540
  • access.redhat.com/errata/RHSA-2019:0237
  • access.redhat.com/errata/RHSA-2019:1352
  • bugzilla.redhat.com/show_bug.cgi?id=CVE-2018-16886
  • github.com/advisories/GHSA-h6xx-pmxh-3wgp
  • github.com/etcd-io/etcd/blob/1eee465a43720d713bb69f7b7f5e120135fdb1ac/CHANGELOG-3.2.md
  • github.com/etcd-io/etcd/blob/1eee465a43720d713bb69f7b7f5e120135fdb1ac/CHANGELOG-3.3.md
  • github.com/etcd-io/etcd/commit/0191509637546621d6f2e18e074e955ab8ef374d
  • github.com/etcd-io/etcd/commit/bf9d0d8291dc71ecbfb2690612954e1a298154b2
  • github.com/etcd-io/etcd/pull/10366
  • lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/JX7QTIT465BQGRGNCE74RATRQLKT2QE4/
  • lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/UPGYHMSKDPW5GAMI7BEP3XQRVRLLBJKS/
  • nvd.nist.gov/vuln/detail/CVE-2018-16886

Code Behaviors & Features

Detect and mitigate CVE-2018-16886 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions starting from 3.2.0 before 3.2.26, all versions starting from 3.3.0 before 3.3.11

Fixed versions

  • 3.2.26
  • 3.3.11

Solution

Upgrade to versions 3.2.26, 3.3.11 or above.

Impact 8.1 HIGH

CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H

Learn more about CVSS

Weakness

  • CWE-287: Improper Authentication

Source file

go/go.etcd.io/etcd/v3/CVE-2018-16886.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:15:43 +0000.