Advisory Database
  • Advisories
  • Dependency Scanning
  1. golang
  2. ›
  3. go.etcd.io/etcd/client/v3
  4. ›
  5. CVE-2020-15115

CVE-2020-15115: Weak Password Requirements

October 6, 2022

etcd before versions 3.3.23 and 3.4.10 does not perform any password length validation, which allows for very short passwords, such as those with a length of one. This may allow an attacker to guess or brute-force users’ passwords with little computational effort.

References

  • github.com/advisories/GHSA-4993-m7g5-r9hh
  • github.com/etcd-io/etcd/security/advisories/GHSA-4993-m7g5-r9hh
  • nvd.nist.gov/vuln/detail/CVE-2020-15115

Code Behaviors & Features

Detect and mitigate CVE-2020-15115 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 3.3.23, all versions starting from 3.4.0 before 3.4.10

Fixed versions

  • 3.3.23
  • 3.4.10

Solution

Upgrade to versions 3.3.23, 3.4.10 or above.

Impact 7.5 HIGH

CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N

Learn more about CVSS

Weakness

  • CWE-521: Weak Password Requirements

Source file

go/go.etcd.io/etcd/client/v3/CVE-2020-15115.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:21 +0000.