Advisory Database
  • Advisories
  • Dependency Scanning
  1. golang
  2. ›
  3. github.com/usememos/memos
  4. ›
  5. CVE-2022-4687

CVE-2022-4687: Incorrect Use of Privileged APIs

December 23, 2022 (updated December 30, 2022)

Incorrect Use of Privileged APIs in GitHub repository usememos/memos prior to 0.9.0.

References

  • github.com/advisories/GHSA-fv6c-rfg3-gvjw
  • github.com/usememos/memos/commit/dca35bde877aab6e64ef51b52e590b5d48f692f9
  • huntr.dev/bounties/b908377f-a61b-432c-8e6a-c7498da69788
  • nvd.nist.gov/vuln/detail/CVE-2022-4687

Code Behaviors & Features

Detect and mitigate CVE-2022-4687 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 0.9.0

Fixed versions

  • v0.9.0

Solution

Upgrade to version 0.9.0 or above.

Impact 8.1 HIGH

CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N

Learn more about CVSS

Weakness

  • CWE-648: Incorrect Use of Privileged APIs

Source file

go/github.com/usememos/memos/CVE-2022-4687.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:46 +0000.