Advisory Database
  • Advisories
  • Dependency Scanning
  1. golang
  2. ›
  3. github.com/openfga/openfga
  4. ›
  5. CVE-2022-39340

CVE-2022-39340: Incorrect Authorization

October 25, 2022

OpenFGA is an authorization/permission engine. Prior to version 0.2.4, the streamed-list-objects endpoint was not validating the authorization header, resulting in disclosure of objects in the store. Users openfga/openfga versions 0.2.3 and prior who are exposing the OpenFGA service to the internet is vulnerable. Version 0.2.4 contains a patch for this issue.

References

  • github.com/advisories/GHSA-95x7-mh78-7w2r
  • github.com/openfga/openfga/commit/779d73d4b6d067ee042ec9b59fec707eed71e42f
  • github.com/openfga/openfga/releases/tag/v0.2.4
  • github.com/openfga/openfga/security/advisories/GHSA-95x7-mh78-7w2r
  • nvd.nist.gov/vuln/detail/CVE-2022-39340

Code Behaviors & Features

Detect and mitigate CVE-2022-39340 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions up to 0.2.3

Fixed versions

  • v0.2.4

Solution

Upgrade to version 0.2.4 or above.

Impact 5.3 MEDIUM

CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N

Learn more about CVSS

Weakness

  • CWE-863: Incorrect Authorization

Source file

go/github.com/openfga/openfga/CVE-2022-39340.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:05 +0000.