Advisory Database
  • Advisories
  • Dependency Scanning
  1. golang
  2. ›
  3. github.com/opencontainers/runc
  4. ›
  5. CVE-2019-16884

CVE-2019-16884: Incorrect Authorization

February 22, 2022 (updated February 26, 2022)

runc through 1.0.0-rc8, as used in Docker through 19.03.2-ce and other products, allows AppArmor restriction bypass because libcontainer/rootfs_linux.go incorrectly checks mount targets, and thus a malicious Docker image can mount over a /proc directory.

References

  • lists.opensuse.org/opensuse-security-announce/2019-10/msg00073.html
  • lists.opensuse.org/opensuse-security-announce/2019-11/msg00009.html
  • lists.opensuse.org/opensuse-security-announce/2020-01/msg00010.html
  • access.redhat.com/errata/RHSA-2019:3940
  • access.redhat.com/errata/RHSA-2019:4074
  • access.redhat.com/errata/RHSA-2019:4269
  • github.com/advisories/GHSA-fgv8-vj5c-2ppq
  • github.com/crosbymichael/runc/commit/78dce1cf1ec36bbe7fe6767bdb81f7cbf6d34d70
  • github.com/opencontainers/runc/issues/2128
  • github.com/opencontainers/runc/pull/2129
  • lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/62OQ2P7K5YDZ5BRCH2Q6DHUJIHQD3QCD/
  • lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/DGK6IV5JGVDXHOXEKJOJWKOVNZLT6MYR/
  • lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/SPK4JWP32BUIVDJ3YODZSOEVEW6BHQCF/
  • nvd.nist.gov/vuln/detail/CVE-2019-16884
  • security.gentoo.org/glsa/202003-21
  • security.netapp.com/advisory/ntap-20220221-0004/
  • usn.ubuntu.com/4297-1/

Code Behaviors & Features

Detect and mitigate CVE-2019-16884 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions up to 1.0.0-rc8

Fixed versions

  • v1.0.0-rc9

Solution

Upgrade to version 1.0.0-rc9 or above. *Note*: 1.0.0-rc9 may be an unstable version. Use caution.

Impact 7.5 HIGH

CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N

Learn more about CVSS

Weakness

  • CWE-863: Incorrect Authorization

Source file

go/github.com/opencontainers/runc/CVE-2019-16884.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:15:54 +0000.