Advisory Database
  • Advisories
  • Dependency Scanning
  1. golang
  2. ›
  3. github.com/nyaruka/phonenumbers
  4. ›
  5. CVE-2025-10954

CVE-2025-10954: github.com/nyaruka/phonenumbers Vulnerable to Improper Validation of Syntactic Correctness of Input

September 27, 2025 (updated September 29, 2025)

Versions of the package github.com/nyaruka/phonenumbers before 1.2.2 are vulnerable to Improper Validation of Syntactic Correctness of Input in the phonenumbers.Parse() function. An attacker can cause a panic by providing crafted input causing a “runtime error: slice bounds out of range”.

References

  • github.com/advisories/GHSA-fmjh-f678-cv3x
  • github.com/nyaruka/phonenumbers
  • github.com/nyaruka/phonenumbers/commit/0479e35488e8a002a261cdb515ef8a7f80ca37fe
  • github.com/nyaruka/phonenumbers/issues/148
  • nvd.nist.gov/vuln/detail/CVE-2025-10954
  • security.snyk.io/vuln/SNYK-GOLANG-GITHUBCOMNYARUKAPHONENUMBERS-6084070

Code Behaviors & Features

Detect and mitigate CVE-2025-10954 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 1.2.2

Fixed versions

  • 1.2.2

Solution

Upgrade to version 1.2.2 or above.

Impact 5.3 MEDIUM

CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L

Learn more about CVSS

Weakness

  • CWE-1286: Improper Validation of Syntactic Correctness of Input

Source file

go/github.com/nyaruka/phonenumbers/CVE-2025-10954.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:15:57 +0000.