Advisory Database
  • Advisories
  • Dependency Scanning
  1. golang
  2. ›
  3. github.com/mattermost/mattermost-server
  4. ›
  5. CVE-2026-3433

CVE-2026-3433: Mattermost doesn't restrict role_updated websocket event broadcasts to members of the affected team or channel

June 12, 2026 (updated August 24, 2026)

Mattermost versions 11.6.x <= 11.6.1, 11.5.x <= 11.5.4, 10.11.x <= 10.11.15, 10.11.x <= 10.11.16 fail to restrict role_updated websocket event broadcasts to members of the affected team or channel, which allows an authenticated attacker with guest-level access to observe permission scheme change notifications for private teams they are not a member of via the websocket connection. Mattermost Advisory ID: MMSA-2026-00616

References

  • github.com/advisories/GHSA-rp4v-qc77-phm4
  • github.com/mattermost/mattermost/commit/0a0ab0d54d899d308bd1352cc577036917500318
  • github.com/mattermost/mattermost/commit/7425c6817bf244f976c729f8a73cecac8039a1e1
  • github.com/mattermost/mattermost/commit/9408b98025d7364d7dfe7cdb28fcd109b1b595a6
  • github.com/mattermost/mattermost/commit/a30a331a29b9766d46716d4252056d7b74e66da0
  • github.com/mattermost/mattermost/pull/35497
  • github.com/mattermost/mattermost/pull/36256
  • github.com/mattermost/mattermost/pull/36257
  • github.com/mattermost/mattermost/pull/36341
  • github.com/mattermost/mattermost/releases/tag/v10.11.16
  • github.com/mattermost/mattermost/releases/tag/v11.5.5
  • github.com/mattermost/mattermost/releases/tag/v11.6.2
  • github.com/mattermost/mattermost/releases/tag/v11.7.0
  • mattermost.com/security-updates
  • nvd.nist.gov/vuln/detail/CVE-2026-3433

Code Behaviors & Features

Detect and mitigate CVE-2026-3433 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions starting from 10.11.0 before 10.11.17, all versions starting from 11.5.0 before 11.5.5, all versions starting from 11.6.0 before 11.6.1

Fixed versions

  • 10.11.17
  • 11.5.5
  • 11.6.1

Solution

Upgrade to versions 10.11.17, 11.5.5, 11.6.1 or above.

Impact 4.3 MEDIUM

CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N

Learn more about CVSS

Weakness

  • CWE-200: Exposure of Sensitive Information to an Unauthorized Actor

Source file

go/github.com/mattermost/mattermost-server/CVE-2026-3433.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:25 +0000.