Advisory Database
  • Advisories
  • Dependency Scanning
  1. golang
  2. ›
  3. github.com/mattermost/mattermost-server
  4. ›
  5. CVE-2025-6227

CVE-2025-6227: Mattermost has Insufficiently Protected Credentials

July 18, 2025 (updated July 21, 2025)

Mattermost versions 10.5.x <= 10.5.7, 9.11.x <= 9.11.16 fail to negotiate a new token when accepting the invite which allows a user that intercepts both invite and password to send synchronization payloads to the server that originally created the invite via the REST API.

References

  • github.com/advisories/GHSA-4fwj-8595-wp25
  • github.com/mattermost/mattermost
  • github.com/mattermost/mattermost/commit/fbf105f6ef8f6cd5a89f859f09a2d1216cd81c05
  • mattermost.com/security-updates
  • nvd.nist.gov/vuln/detail/CVE-2025-6227

Code Behaviors & Features

Detect and mitigate CVE-2025-6227 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions starting from 9.11.0 before 9.11.17, all versions starting from 10.5.0 before 10.5.8

Fixed versions

  • 10.5.8
  • 9.11.17

Solution

Upgrade to versions 10.5.8, 9.11.17 or above.

Impact 2.2 LOW

CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:U/C:N/I:L/A:N

Learn more about CVSS

Weakness

  • CWE-522: Insufficiently Protected Credentials

Source file

go/github.com/mattermost/mattermost-server/CVE-2025-6227.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:17:05 +0000.