Advisory Database
  • Advisories
  • Dependency Scanning
  1. golang
  2. ›
  3. github.com/mattermost/mattermost-server
  4. ›
  5. CVE-2018-21258

CVE-2018-21258: Mattermost Server is vulnerable to a Denial of Service attack through `invite_people` command

May 24, 2022 (updated November 20, 2025)

An issue was discovered in Mattermost Server before 5.1.0. It allows attackers to cause a denial of service via the invite_people slash command.

References

  • github.com/advisories/GHSA-5mh6-p63g-3mv5
  • github.com/mattermost/mattermost
  • github.com/mattermost/mattermost/commit/af615ffc24b774d76deef8c93282831432669dd8
  • mattermost.com/security-updates
  • nvd.nist.gov/vuln/detail/CVE-2018-21258

Code Behaviors & Features

Detect and mitigate CVE-2018-21258 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 5.1.0

Fixed versions

  • 5.1.0

Solution

Upgrade to version 5.1.0 or above.

Impact 7.5 HIGH

CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Learn more about CVSS

Weakness

  • CWE-400: Uncontrolled Resource Consumption

Source file

go/github.com/mattermost/mattermost-server/CVE-2018-21258.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:05 +0000.