Advisory Database
  • Advisories
  • Dependency Scanning
  1. golang
  2. ›
  3. github.com/mattermost/mattermost-server
  4. ›
  5. CVE-2017-18906

CVE-2017-18906: Mattermost Server vulnerable to user account takeover when Single Sign-On OAuth2 is used

May 24, 2022 (updated February 10, 2026)

An issue was discovered in Mattermost Server before 4.0.0, 3.10.2, and 3.9.2, when Single Sign-On OAuth2 is used. An attacker could claim somebody else’s account.

References

  • github.com/advisories/GHSA-fpcr-4rr5-hpcp
  • github.com/mattermost/mattermost
  • github.com/mattermost/mattermost/commit/259ad46f30d0fac2f7c5c14f3b76b2170f7e90c7
  • github.com/mattermost/mattermost/commit/b17fca0d5ee7557e3df1cf1d1da8bd749859e35f
  • github.com/mattermost/mattermost/commit/fbc170733e86f09b46ba754dd03304733d2f482f
  • mattermost.com/security-updates
  • nvd.nist.gov/vuln/detail/CVE-2017-18906

Code Behaviors & Features

Detect and mitigate CVE-2017-18906 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions starting from 3.10.0 before 3.10.2

Fixed versions

  • 3.10.2

Solution

Upgrade to version 3.10.2 or above.

Impact 8.1 HIGH

CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N

Learn more about CVSS

Weakness

  • CWE-613: Insufficient Session Expiration

Source file

go/github.com/mattermost/mattermost-server/CVE-2017-18906.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:14 +0000.