Advisory Database
  • Advisories
  • Dependency Scanning
  1. golang
  2. ›
  3. github.com/mattermost/mattermost-server
  4. ›
  5. CVE-2017-18877

CVE-2017-18877: Mattermost Server is vulnerable to XSS attacks against an OAuth 2.0 allow/deny page

May 24, 2022 (updated December 5, 2025)

An issue was discovered in Mattermost Server before 4.3.0, 4.2.1, and 4.1.2. XSS attacks could occur against an OAuth 2.0 allow/deny page.

References

  • github.com/advisories/GHSA-9x8x-w6g5-hx4w
  • github.com/mattermost/mattermost
  • mattermost.com/security-updates
  • nvd.nist.gov/vuln/detail/CVE-2017-18877

Code Behaviors & Features

Detect and mitigate CVE-2017-18877 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 4.1.2, all versions starting from 4.2.0 before 4.2.1, all versions starting from 4.3.0-rc1 before 4.3.0

Fixed versions

  • 4.1.2
  • 4.2.1
  • 4.3.0

Solution

Upgrade to versions 4.1.2, 4.2.1, 4.3.0 or above.

Impact 6.1 MEDIUM

CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N

Learn more about CVSS

Weakness

  • CWE-79: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')

Source file

go/github.com/mattermost/mattermost-server/CVE-2017-18877.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:17:15 +0000.