Advisory Database
  • Advisories
  • Dependency Scanning
  1. golang
  2. ›
  3. github.com/mattermost/mattermost-plugin-playbooks
  4. ›
  5. CVE-2025-41423

CVE-2025-41423: Mattermost Playbooks fails to properly validate permissions

April 24, 2025

Mattermost versions 10.4.x <= 10.4.2, 10.5.x <= 10.5.0, 9.11.x <= 9.11.10 fail to properly validate permissions for the API endpoint /plugins/playbooks/api/v0/signal/keywords/ignore-thread, allowing any user or attacker to delete posts containing actions created by the Playbooks bot, even without channel access or appropriate permissions.

References

  • github.com/advisories/GHSA-fr22-5377-f3p7
  • github.com/mattermost/mattermost-plugin-playbooks
  • github.com/mattermost/mattermost-plugin-playbooks/commit/f9f7064e4d9f3918d66bac1f5f9eb28f0723464b
  • github.com/mattermost/mattermost/commit/2b5275d87136f07e016c8eca09a2f004b31afc8a
  • mattermost.com/security-updates
  • nvd.nist.gov/vuln/detail/CVE-2025-41423

Code Behaviors & Features

Detect and mitigate CVE-2025-41423 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 1.41.0, all versions starting from 2.0.0

Fixed versions

  • 1.41.0

Solution

Upgrade to version 1.41.0 or above.

Impact 3.1 LOW

CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:N/I:L/A:N

Learn more about CVSS

Weakness

  • CWE-863: Incorrect Authorization

Source file

go/github.com/mattermost/mattermost-plugin-playbooks/CVE-2025-41423.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:41 +0000.