Advisory Database
  • Advisories
  • Dependency Scanning
  1. golang
  2. ›
  3. github.com/mattermost/mattermost-plugin-confluence
  4. ›
  5. CVE-2025-54525

CVE-2025-54525: Mattermost Confluence Plugin has Improper Validation of Specified Type of Input

August 11, 2025 (updated August 12, 2025)

Mattermost Confluence Plugin versions < 1.5.0 fail to handle unexpected request bodies, allowing attackers to crash the plugin via constant hits to the create channel subscription endpoint with an invalid request body.

References

  • github.com/advisories/GHSA-3cg3-3mmr-w8hj
  • github.com/mattermost/mattermost-plugin-confluence
  • mattermost.com/security-updates
  • nvd.nist.gov/vuln/detail/CVE-2025-54525

Code Behaviors & Features

Detect and mitigate CVE-2025-54525 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 1.5.0

Fixed versions

  • 1.5.0

Solution

Upgrade to version 1.5.0 or above.

Impact 7.5 HIGH

CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Learn more about CVSS

Weakness

  • CWE-1287: Improper Validation of Specified Type of Input

Source file

go/github.com/mattermost/mattermost-plugin-confluence/CVE-2025-54525.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:07 +0000.